Swen Trojan problem

Hope someone can help me as I’m out of ideas :frowning:
Avast has located a swen worm in 2 places on my PC and this info is in the scan log. I cannot delete, repair, rename or put them in the chest…When I go through the delele process it just does not go >:(

C:\Documents and Settings\Weirdy\Application Data\Application Data\Microsoft\Outlook\outlook.pst\Personal Folders\Top of Personal Folders\Deleted Items\Newest Network Security Pack\patch.exe [L] Win32:Swen [Wrm] (0)
During the file delete, error occurred: Error 0x80040119.
C:\Documents and Settings\Weirdy\Application Data\Microsoft\Outlook\outlook.pst\Personal Folders\Top of Personal Folders\Deleted Items\Newest Network Security Pack\patch.exe [L] Win32:Swen [Wrm] (0)
During the file delete, error occurred: Error 0x80040119.
Can anyone help please :wink:

Hi,

  • pause all avast shields/providers, and then open outlook:
  • make sure that you have auto-opening of attachments/autopreview pane disabled (search board or outlook help for this)
  • delete the mail with subject Newest Network Security Pack in Trash/Deleted Items (or delete all items in trash)
  • compact trash and all other mailboxes
  • close outlook, and reenable avast shields/providers :wink:

do a full scan with avast :wink:

S wiped this from the the following web page

http://support.microsoft.com/?kbid=814441

OL2002: “0x80040119” and “Unknown Error” Error Messages When You Try to Read, Send, Receive, or Delete E-mail
Applies To
SYMPTOMS
When you try to read e-mail in your Outlook Inbox, or when you click Send/Receive, you may receive the following error message:

An unknown error has occurred. 0x80040119
When you try to delete e-mail, you may receive the following error message:

Messaging interface has caused an unknown error
CAUSE
This issue may occur if your .pst file is damaged or is locked open by another process.
RESOLUTION
Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

To resolve this issue, try to repair the PST file. To do this, follow these steps:
Quit Outlook.
Locate your Outlook PST file. To do this, use one of the following methods.
Method 1: Search for the PST File
Click Start, and then click Search.
Click All Files and Folders.
In the All or part of the file name box, type *.pst. By default, the name of your Outlook PST file is Outlook.pst, but it may be different on your computer.
Change the selection in the Look in box to your local hard disk (for example, Local Disk (C:)).
Click Search.
Method 2: Check Your Mail Setup
Click Start, and then click Control Panel.
Click Other Control Panel Options.
Click Mail.
In the Mail Setup - Outlook dialog box, click Data Files.
In the Outlook Data Files - Outlook dialog box, click Open Folder.

The Address box will contain the path of your Outlook PST file.
The Inbox Repair Tool should already be installed on your computer. To verify the location of the tool, follow these steps:
Click Start, and then click Search.
Click All Files and Folders.
In the All or part of the file name box, type Scanpst.exe.
Change the selection in the Look in box to your local hard disk (for example, Local Disk (C:)).
Click Search.
Run the Inbox Repair Tool. To do this, follow these steps:
Click Start, and then click Run.
In the Open box, type the path of the Scanpst.exe file that you located in step 3. For example, type (or navigate to) C:\Program Files\Common Files\System\Mapi\1033\Scanpst.exe.
Click OK to run the Inbox Repair Tool.
In the Enter the name of the file you want to scan box, type (or navigate to) the path and file name of the Outlook PST file that you located in step 2.
Click Start.
After the Inbox Repair Tool operation has completed, click OK.
MORE INFORMATION
For additional information about the Inbox Repair Tool, click the following article number to view the article in the Microsoft Knowledge Base:
287497 OL2002: How to Use the Inbox Repair Tools to Recover Messages

The information in this article applies to:
Microsoft Office Outlook 2003
Microsoft Outlook 2002

??? I have a similar problem with Avast 4.6 pro…only this is really a lot weirder. When I had it scan my PST file outside Outlook 2003 (and Outlook not running), it found the following entries:

  • 12-8-2005 14:53:28 Remco 3008 Sign of “Win32:Swen [Wrm]” has been found in “D:\email\Outlook\OS.pst\Persoonlijke mappen\Hoofdmap van persoonlijke mappen\Verwijderde items\Newest Network Critical Patch\Pack888.exe” file.
  • 12-8-2005 14:54:10 Remco 1772 Sign of “Win32:Swen [Wrm]” has been found in “D:\email\Outlook\Outlook.pst\Persoonlijke mappen\Hoofdmap van persoonlijke mappen\Verwijderde items\Newest Network Critical Patch\Pack888.exe” file.

I told it to delete it, but it warned me that it failed to. Than when I opened Outlook and looked for the email/file containing this worm there was nothing there! Not one single email in Deleted Items (which is the translation for the dutch ‘Verwijderde Items’). Although the PST is working like a charm and I have no problems in Outlook whatsoever I will try repairing/compressing the PST and hope this will solve it, but it doesn’t feel good to have had a virus warning and not be sure that the virus is gone…tbc!

Newey: Great…it did the trick. Scanpst.exe’s logfile indicated that with both PST’s there were some problems. It fixed the PST and when I scanned them afterwards, no virusses came up! Problem (and mistery) solved!